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SimaPro 8.0.4 Update Instructions

1 Introduction
This document describes how to update your current software and database from SimaPro 7.3.3 and SimaPro 8.0.0,
8.0.1, 8.0.2 or 8.0.3 to the new SimaPro 8.0.4. In the “What’s new in SimaPro 8.0.4” document you find information
about the changes in the data, methods and software.
You will find detailed instructions below. Please read these carefully. Should you still have questions, please contact
your local SimaPro partner or the PRé helpdesk by email at support@pre-sustainability.com. You may also contact us by
phone at +31 33 4504010.

A summary of the update procedure
The update procedure can be summarised as follows:
1.
2.

3.
4.

Software update: Update your SimaPro 8 or SimaPro 7.3.3. single-user or multi-user client software to
SimaPro 8.0.4.
Database update: Import the update database which includes the updated ecoinvent 3.1 allocation default
and consequential libraries, the new ecoinvent 3.1 recycled content (or cut-off) libraries and updated methods
library. Also included are all other new or updated libraries released with SimaPro 8.0.0 to 8.0.3. These need to
be imported by those users that update from SimaPro 7.3.3 or users that have not yet imported all database
updates released with SimaPro 8.
Append substances: Perform an Append action to merge synonymous substance names in the substance list
and bring them in line with the latest SimaPro nomenclature.
Update projects to ecoinvent v3.1: Use the “Projects to Libraries Links Manager” to
replace links to the ecoinvent 2.2 libraries with links to one of the new ecoinvent 3.1 libraries.
replace links from the ecoinvent 3.1 allocation default library to the ecoinvent 3.1 recycled content library.

2 Updating the SimaPro software
2.1 Multi-user versions
We recommend that multi-user updates are done by your network administrator. Please note that:
 All SimaPro 7.3 or 8.0.x multi-user clients have to be updated to SimaPro 8.0.4.
 The SimaPro Database Server software does not need to be updated.

2.2 Procedure for updating single-user and multi-user client
The procedure for updating the single-user and multi-user SimaPro client software is as follows:
1.

2.

3.

Download the SimaPro installation file SetupSimaPro804.zip from http://www.pre-sustainability.com/simaproinstallation to each computer that runs the SimaPro single-user or SimaPro multi-user client. The zip file
contains the installers for the software and database update.
On each computer, unzip SetupSimaPro804.zip and double-click SetupSimaPro804.exe to start the installation.
Follow the instructions in the setup wizard. The current SimaPro software will be uninstalled and then replaced
with SimaPro 8.0.4. Note that your database(s) will not be uninstalled! You may be asked for your SimaPro
registration name and code.
Next, proceed with the database update procedure as described below.

3

3 Updating the database
3.1 Database update
This chapter describes how to update your database. The update process consists of three parts:
1.
2.
3.

Installing the update database that contains the new data.
Importing the update database into your SimaPro database(s).
Doing an append action to merge synonyms in the substance list.

These steps are described in detail in the following sections. In Box 1 and 2 you will find tips for updating multi-user
licences and an overview of the default database locations. You have to follow the database update procedure for each
SimaPro database that you want to update.
Please note that any changes you made to the library entries (e.g. additions to an ecoinvent library) or the original
methods supplied in the Methods library will be lost during the update. Data that you added to the libraries that are to
be updated will still be there. Contact us for assistance if you wish to keep your changes.
Box 1. Updating a database in a multi-user environment
In a multi-user environment, updating a database directly on the database server is very slow due to additional
network traffic. The update can take several hours, in the worst case up to 15 hours or more. If you have one of the
professional multi-user licences (Compact, Analyst or Developer), you can also do the database update locally on a
(fast) PC with the SimaPro client installed. This is much quicker.
To copy the database, login as Manager and check under Tools, User Management that no users are logged into the
SimaPro database. If so, you can close SimaPro. Locate the database on the server’s hard drive (see Box 2 for
default locations) and copy the database (a set of 77 numbered *.NX1 files) to your local hard drive. In the “Open
SimaPro Database” window, choose “Local server”, browse to the directory you copied the database to. Continue
with the update instructions in section 3.2. After updating, copy the database back to its original location on the
server.
Owners of an educational Classroom licence do not have “local server” database access, but should request a
temporary single-user licence via support@pre-sustainability.com to do the update locally. We will include
instructions on how to do this.

Box 2. Default directories
SimaPro installs updates in the default database directory if no other location is chosen. Which directory is the
default depends on the version of Windows your database server is running:



Windows 7, Windows 8, Windows 2008 server, Windows 2012 server:
C:\Users\Public\Documents\SimaPro\Database\
Windows 2003 server: C:\Documents and Settings\All Users\Shared Documents\SimaPro\Database

If you have a multi-user version and cannot find the database in one of the default directories, open the SimaPro
database server. In the list of aliases you can see the location(s) of the database directories that are being used.
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3.2 Installing the update database
In the location where you unzipped the SetupSimaPro804.zip files to, double-click SetupUpdateDatabase804.exe to
install the “Update804” database. You have to do this on each computer with SimaPro single user installed. For the
multi-user, one installation is sufficient.
The “Update804” database will be installed in the default directory (see Box 2 above). Follow the instructions in the
setup wizard. This process will install the update database 8.0.4 on your computer, but it will not yet update the active
databases.
Multi-user version: since we recommend doing the database update locally, the update database does not have to be
installed in one of the locations (directory aliases) defined in the SimaPro database server. Instead, you can do the
update on a local hard drive and then copy your updated database back to the server (see Box 1).
If you notice any older update databases (named Update800, Update801, Update802, Update803 or similar), you can
delete these with Windows Explorer to free up disk space and avoid confusion. To avoid deleting useful databases by
accident, please open each database before deleting it to check for any projects that need to be kept.

3.3 Importing the update database
Follow these steps to import the new data:
1.

2.

Start SimaPro 8.0.4. If you have a multi-user SimaPro licence, log in as Manager. Make sure no other users are
logged in at this moment, because the database will be locked during import. During the update process, users
cannot log in to SimaPro.
On opening the database a technical conversion will take place which does not alter the content of your database.
However, after conversion the database cannot be opened with any previous versions of SimaPro anymore.
SimaPro will create a (obligatory) backup of your database. Click Yes to continue.

Once the backup and conversion are completed, the database will be opened.
3.

4.

Check if the database you want to update is open in SimaPro. The database name is found in the blue bar at the
top of the SimaPro window. If the database is not open, go to File> Open SimaPro Database and select the
database you want to update (the database you usually work in).
Go to File > Import SimaPro Database. Click “Yes” to continue when the message below appears. Click Yes and
specify the location where the backup must be stored.
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5.

The “Import SimaPro Database” dialogue box will appear:

6.

Click “Browse”. The “Open database” dialogue box will appear (“local server” is shown in multi-user versions only):

7.

Click “Browse”. Browse to the directory where you installed the update database, select the “Update804”
database (see Box 2 for the default directory) and click “OK”.
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8.

The update database (Update804) will appear in the “Open Database” dialogue box. Click “Open”. Click “Select all”
at the bottom left of the window. Deselect any of the libraries you have already imported in a previous update
(this could be ELCD, USLCI, Agri-footprint). If you are updating from SimaPro 8, the minimum you should import
are the “ecoinvent 3 – allocation, default” and “ecoinvent v3 – consequential” unit and systems libraries (to
update your ecoinvent 3.0.1 ecoinvent 3 libraries) and the Methods library. Next, click “Import”.
9. The data will be scanned and an overview will be generated of all the data that are added or replaced. We
recommend that you save this overview. Note this process can take a long time (up to 30 minutes), during which
SimaPro may seem non responsive, which is normal.
10. Click “OK” to start the import process. Before data importing starts, the program will prompt you to make a
backup.

After clicking “OK”, select the folder you want the save to backup file in (for example, the default directory; see
Box 2). Note: if you click “Cancel”, the update procedure is stopped.
11. The data in the update database will now be imported into the existing database. Note that this may take up to
several hours and that occasionally, the software may look ‘frozen’ for several minutes as it runs the import. This
is nothing to worry about.
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After importing the update database, continue to the Append substances step.

Box 3. Import errors
Should SimaPro report any import errors, please save the log file and make screenshots if possible. The overview of
issues in the log file may help you to find out what went wrong. For assistance, please send an email to the SimaPro
helpdesk at support@pre-sustainability.com and include the log file and any screenshots as attachments.
We appreciate it if you could include the results of the database check, which can be done via File > SimaPro
Database Management > Check Database.

3.4 Doing append action on substances
The next step is to do an “append substances” action to convert some old substance names in your database to the
latest substance naming convention in SimaPro. If you do not do this, mismatches between life cycle inventory and
impact assessment data may occur, leading to incorrect LCA results. The replacements are defined in the append file
that is installed with the update database.
Appending merges two synonymous substance names into one. For example, CO 2 needs to be appended to Carbon
dioxide, the latter being the name used in the most recent version of SimaPro and in the impact assessment methods.
Without appending CO2 to Carbon dioxide, any use of the substance named CO2 in processes will not show in the
impact assessment results.
1.
2.
3.
4.
5.
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Before executing the append action, we recommend you create a backup of the fully updated database via File >
Database Management > Backup/Restore > Backup.
Go to the “Substances” section under “General Data” in the LCA Explorer screen.
Click “Append”. A new window will open.
Click “Load” on the right hand side and select the append file: “AppendSubstances804.xls”. The append file is found
in the same directory as the update database (see Box 2 for default directories).
Click “Append” on the right hand side of the window. After a final confirmation, the substances will be appended.
Depending on the size of your database, this may take some time.
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3.5 Transferring project to library links
In SimaPro 8.0.3, a new function was introduced called the “Projects to libraries links manager”. In SimaPro 8.0.4, the
Projects to libraries links manager can be used to replace the links in projects to processes in one or more (old
ecoinvent) libraries to equivalent processes in other (new ecoinvent) libraries. This tool substitutes the transfer
function which was present in SimaPro 8.0.0 to 8.0.3.
PRé created special Replacement files to allow you to change the links in your project to your preferred ecoinvent 3.1
library. This way it is possible to quickly transfer your links with the following libraries:





Ecoinvent 2.2 to ecoinvent 3.1 Allocation default: for all users who
1) want to update from ecoinvent 2.2 to the 3.1 Allocation default library
2) have updated to 3.0.1 earlier (see Box 4). If you have used the transfer function in earlier versions of SimaPro 8
the projects transferred from ecoinvent 2.2 to ecoinvent 3 have the suffix EI3. You can use the filter to select
only the processes with “EI3” in the name. This way you avoid that the original projects (still linking to
ecoinvent v2.2) are relinked to ecoinvent 3.1. If you have continued working in projects using ecoinvent v2.2
and you want to transfer the links to ecoinvent 3.1, we recommend you make a copy of the project first before
you replace the links. Make sure you keep a proper log of the projects in which you replaced the links!
Ecoinvent 2.2 to ecoinvent 3.1 Allocation recycled content: for users that are still working with ecoinvent v2.2 and
want to update their project to this system model.
Ecoinvent 3.1 Allocation default to ecoinvent 3.1 Allocation recycled content: once you carried out the transfer
from ecoinvent v2.2 to ecoinvent v3.1 allocation default, you can use this replacement file to change the links to
the ecoinvent 3.1 Allocation recycled content system model. We recommend you make a copy of the project first
before you replace the links. See also Box 4.

Note that 100% replacement is not possible. You can create your own replacement file for remaining processes as
described below.
Replacement files for obsolete SimaPro waste treatment processes
For the users who want to continue working with the 3.1 Allocation default and/or consequential libraries, it is
important to replace the obsolete waste treatment processes. Obsolete processes are library processes that do not
exist in the current version of a library, for example because they became outdated or have been replaced with
processes that do not match the content. We cannot delete these processes during an update. Therefore we mark
them as “obsolete” and move these processes to a subcategory “obsolete”. SimaPro shows a warning message if you
make a calculation in which obsolete processes are used. You can then update your model with newer processes.
The waste treatment processes in ecoinvent 3.0.1 with “(waste treatment)” added to the process name were created
by PRé in order to be used in a waste scenario. With the new approach of handling waste treatment processes they
have become “obsolete” in ecoinvent 3.1 (see the “What’s new in SimaPro 8.0.4” document). Links to these processes
will be replaced with links to the new ecoinvent 3.1 waste treatment processes with this replacement action, so that
your model is consistent.
If you have updated from ecoinvent 3.0.1 Allocation default and/or ecoinvent 3.0.1 Consequential libraries to
ecoinvent 3.1 Allocation default and/or ecoinvent 3.1 Consequential libraries.



Replace waste treatment EI3.0.1 allocation default to EI3.1 allocation default.
Replace waste treatment EI3.0.1 consequential to EI3.1 consequential.

Note: If the “Projects to libraries links manager” shows that no replacements are found, you have not created any links
to the processes in your project.
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Box 4. Bug in transfer function of SimaPro 8.0.3
We found a bug in the transfer function of SimaPro 8.0.3. In certain situations this version of SimaPro did an
incomplete transfer of links, leaving links to ecoinvent 2.2 which should have been transferred to ecoinvent 3.0.1.
Please note that there was not a 100% match between ecoinvent v2.2 and v3.01 processes, therefore a complete
replacement is not possible. Chances are very high that you will still see ecoinvent v2.2 processes in transferred
projects. This is not automatically related to the bug we found.
Users who did the transfer of their projects with SimaPro version 8.0.3 can solve the problem easily. By using the
Projects to Libraries Links Manager and the “ecoinvent 2.2 to ecoinvent 3.1 allocation default” replacement file any
remaining links that were not replaced due to the bug in the transfer function in SimaPro 8.0.3 will be replaced.
Please note that this action can only be done after importing the Update804 database which replaces ecoinvent
v3.0.1 with ecoinvent v3.1.

Using the replacement file
Follow the next steps for replacing the links in your project to your present library to the preferred library using one of
the replacement file:
1.
2.
3.

Open a project in your updated database. This can be any project.
Open the Project to library links manager window by going to Tools>Project to library Links Manager.
Select the project(s) of which you want to change links (press Ctrl-A to select all projects and Ctrl-Shift-A to
deselect). You can use the filter to select project by (part of the) name.
4. Select the ecoinvent libraries where you want to transfer your links from and to.
5. Click on Scan.
6. View the links found by clicking on the Links tab.
7. Click on the “Import replacements” button.
8. Load the appropriate Replacement file which can be found in the database directory (see Box 1)
9. Check the links which are going to be replaced in the column ‘Replace name’.
10. Store your links in order to be able to check afterwards. It is also possible to add new replacement links
yourself.
11. Click on Replace to replace the links to the chosen library. You will get a message how many links are replaced
to the chosen library.
Create your own replacement file
After replacing your links to the chosen library, you can check how many links to the previous library are still present.
You can manually select replacement processes in the preferred library. Note that ecoinvent 2.2 processes will not be
updated anymore.
1.
2.
3.
4.
5.
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Select the ecoinvent libraries where you want to transfer your links from and to.
Click on Scan
Now, you have got an overview of all links. The column ‘Child name’ shows the library.
Double click on the empty line in the column ’Replace name’
A menu will open in which you can choose an alternative link in the preferred library. Use the function ‘Show
as list’ on the right hand side of the screen to list all links. Filter the links from the preferred library by entering
the suffix of that library in the filter box at the bottom of your screen.
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6.
7.

8.

Choose the preferred link by clicking on it.
You will get a message ‘* links referencing the same product. Use the selected replacement for them too?’
These are the same links which are used in different projects or within projects. You can choose Yes if you
want to select all the links. If you press No, only the selected link will be replaced.
Click on Replace to replace the links. If you want to replace all links at once and you did not finish the work,
you can export the already selected links to Excel and import it at a later stage by using the buttons Export
replacements and Import replacements.
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